php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12880 arg_separator.output does not get used
Submitted: 2001-08-21 11:54 UTC Modified: 2001-08-22 00:33 UTC
From: dank at cse dot unsw dot edu dot au Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.6 OS: Debian GNU/Linux (potato)
Private report: No CVE-ID: None
 [2001-08-21 11:54 UTC] dank at cse dot unsw dot edu dot au
I set both arg_separator.output and arg_separator.input to ';' in my php.ini,
and when I have a query string of the form

asdf=1;qwerty=2

PHP parses it into 2 separate variables, showing that arg_sepatator.input
works, but when I have PHP generate a query string (by setting the method
to GET in a form) PHP would create

asdf=1&qwerty=2

which it then parses into a single variable asdf (cos the input separator is ';')

thanks,

dan
p.s. both phpinfo() and ini_get have confirmed that the options have been set correctly, so I am guessing it's a bug

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-21 19:08 UTC] jeroen@php.net
It is the browser what puts the & between the vars, because there's no way the browser can see the arg-seperator.

arg_separator.output has only effect on PHP-generated arglists. (IIRC, that's currently only with adding php-session var)

So, this is not a bug.
 [2001-08-22 00:33 UTC] sniper@php.net
Set the arg_separator.input to ';&' and it will
do what you want. 

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 21:01:23 2020 UTC