php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12877 The locale is not taken in charge in strftime
Submitted: 2001-08-21 10:30 UTC Modified: 2001-10-02 18:43 UTC
From: srodriguez at ifrance dot com Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.0.6 OS: Linux
Private report: No CVE-ID: None
 [2001-08-21 10:30 UTC] srodriguez at ifrance dot com
Hi,

The locale is not supported in php-4.0.6.

Example the file t.php:

<?php

setlocale ("LC_TIME", "C");
print (strftime ("%A in Finnish is "));
setlocale ("LC_TIME", "fi_FI");
print (strftime ("%A, in French "));
setlocale ("LC_TIME", "fr_CA");
print (strftime ("%A and in German "));
setlocale ("LC_TIME", "de_DE");
print (strftime ("%A.\n"));
      

?>


used as : 

$  /usr/local/stow/php-4.0.6/bin/php t.php

displays : 

X-Powered-By: PHP/4.0.6
Content-type: text/html

Tuesday in Finnish is Tuesday, in French Tuesday and in 
German Tuesday.



Thanks.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-22 00:27 UTC] sniper@php.net
Then there is something seriously broken
in your system, since this works just fine
for me on Linux..

Are you sure you have those locales installed?

--Jani

 [2001-10-02 18:43 UTC] sniper@php.net
No feedback and can not reproduce.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 25 17:01:27 2024 UTC