php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12845 server error when uploading more than 20 files once
Submitted: 2001-08-19 14:21 UTC Modified: 2001-10-28 17:06 UTC
From: ma at netresearch dot de Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.0.6 OS:
Private report: No CVE-ID: None
 [2001-08-19 14:21 UTC] ma at netresearch dot de
we've got a problem using fileuploads with more than 24 files at the same time. server gives no response anymore. restricting to 24 files would help. 24++ files _work_ with 4.04pl1. i can provide a demoscript for resolving the bug if necessary

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-19 16:30 UTC] sniper@php.net
I can not reproduce this with latest CVS. Please try it:

http://snaps.php.net/

--Jani

 [2001-08-20 04:18 UTC] ma at netresearch dot de
We installed the latest CVS and the problem still exists. The working example with 24++ files (using 4.04pl1 at the moment) can be found under http://starkalender.de/bug/upload.php .

 [2001-08-20 05:22 UTC] ma at netresearch dot de
change to the last message. we switched again to 4.0.6 due to other problems with 4.04pl (nothing serious). the mentioned url links now to a non working version, we created a working one too: http://starkalender.de/bug/upload2.php

 [2001-08-20 19:44 UTC] sniper@php.net
I can not reproduce this problem with my system:

Linux (heavily customized RH 6.2)
Apache 1.3.20 / mod_perl / PHP 4.0.7-dev / PHP 3.0.12

All compiled as DSO's. PHP 4.0.7-dev is the latest
CVS. Almost every extension compiled into it...

So what is your system? Web server?
What is in upload.php ?

--Jani

 [2001-08-23 06:47 UTC] ma at netresearch dot de
the system(s) are 

- Apache/1.3.12, PHP/4.0.6 on Linux (Redhat6.2)
- Apache/1.3.19, PHP/4.0.6 on Linux (Redhat7.1)

here the script does not work. switching to PHP/4.04pl on the same servers or using another liveserver with PHP/4.04pl lets the script work correctly.

the upload.php consists of the following (summarized):

<form method="post" action="<? echo $PHP_SELF ?>"  enctype="multipart/form-data">
<input type="Hidden" name="ID" value="<? echo $ID; ?>">
<input type="Hidden" name="MAX_FILE_SIZE" value="500000">


24+4 times <input type="file" name="PIC03b">


</form>

and after pressing the button, server hangs. 

michael

 [2001-08-23 08:21 UTC] sniper@php.net
Duplicate of #11998


 [2001-10-28 17:06 UTC] sniper@php.net
Fixed in CVS.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Aug 06 02:01:24 2020 UTC