php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12817 problems building apache with libmodphp4.a
Submitted: 2001-08-17 14:31 UTC Modified: 2001-08-18 03:05 UTC
From: mgregory at cimedia dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.6 OS: RH 7.0
Private report: No CVE-ID: None
 [2001-08-17 14:31 UTC] mgregory at cimedia dot com
This seems to be a php problem, not an apache one so I'm posting it here...


When running make on apache with the --activate-module=src/modules/php4/libmodphp4.a configure option mod_php.c throws these erros:

mod_php4.c:28:18: zend.h: No such file or directory
mod_php4.c:29:17: php.h: No such file or directory
mod_php4.c:30:27: php_variables.h: No such file or directory
mod_php4.c:47:21: php_ini.h: No such file or directory
mod_php4.c:48:25: php_globals.h: No such file or directory
mod_php4.c:49:18: SAPI.h: No such file or directory
mod_php4.c:50:22: php_main.h: No such file or directory
mod_php4.c:52:26: zend_compile.h: No such file or directory
mod_php4.c:53:26: zend_execute.h: No such file or directory
mod_php4.c:54:28: zend_highlight.h: No such file or directory
mod_php4.c:55:25: zend_indent.h: No such file or directory
mod_php4.c:57:39: ext/standard/php_standard.h: No such file or directory
make[4]: *** [mod_php4.o] Error 1
make[3]: *** [all] Error 1
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/usr/local/src/apache_1.3.20/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/usr/local/src/apache_1.3.20'
make: *** [build] Error 2

The configure options for php:
--with-mysql --with-oracle=/home/myhome/OraHome

The configure options for apache:
--activate-module=src/modules/php4/libmodphp4.a

Everything is default out of the source tarballs for apache and php.  There are no special modifications to either.  Make is being run as root.  All files are located in the same source directory.  I have tried 3 complete fresh builds to be sure.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-17 14:35 UTC] mgregory at cimedia dot com
BTW: I also tried this on apache 3.1.19 and 3.1.18 with identical results.
 [2001-08-17 14:38 UTC] mgregory at cimedia dot com
I left out the configure option on php for building as an apache module:

--with-apache=../apache_1.3.20
 [2001-08-18 03:05 UTC] sniper@php.net
You didn't read the INSTALL file for instructions.
Please ask support questions on php-install@lists.php.net
mailing list. This is not a bug.

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 07:01:26 2019 UTC