php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #12779 Quote operators
Submitted: 2001-08-15 20:30 UTC Modified: 2010-12-17 12:43 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: NetChains at Yahoo dot com Assigned:
Status: Wont fix Package: *General Issues
PHP Version: 4.0.6 OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2001-08-15 20:30 UTC] NetChains at Yahoo dot com
PHP needs quote operators like Perl's q// and qq//. Thanks.
It would be extremely useful not having to escape double quotes while writing forms (because some variables must be interpolated).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-17 14:02 UTC] hholzgra@php.net
<_sniper_> hartmut: And #12896, NO we don't want another alias..
 [2002-06-17 16:11 UTC] sniper@php.net
I guess Hartmut made a tiny typo.. :)

 [2005-04-01 10:26 UTC] gerhard dot oettl at oesoft dot at
it is not an new alias, it would add new functionality - maybe hard to code but very comfortable for web-designers.
 [2010-12-17 12:43 UTC] jani@php.net
-Status: Open +Status: Wont fix -Package: Feature/Change Request +Package: *General Issues
 [2010-12-17 12:43 UTC] jani@php.net
PHP != Perl.
 [2015-08-28 02:22 UTC] php at tech dot futurequest dot net
Really???  "PHP != Perl"

That is a perfect example of "NIH Syndrome".

It should not matter what language it is from, if what is being requested is useful.  I am literally tired of having to escape quotes in:
echo "...\"bunch\".of.\"HTML\".....";

It also makes visually parsing such lines a royal PITA at times.  If anything, this would go a long ways to promoting better readability of one's source code.

Heredoc and Nowdoc (PHP's alternative solution) can make the code a bit ugly to grok when at 2 or more levels of indention deep.

PHP, of all languages, should have this feature/ability since it is closely tied to outputting HTML (its original mandate).

echo "</\"rant off\">";
--
Terra
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC