php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12657 session problem when run as Apache SAPI
Submitted: 2001-08-08 13:05 UTC Modified: 2001-08-08 13:10 UTC
From: lecoq_tr at hotmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.6 OS: win2000
Private report: No CVE-ID: None
 [2001-08-08 13:05 UTC] lecoq_tr at hotmail dot com
I had to run PHP as DLL rather than EXE because I need to override php.ini settings by using .htaccess

As an EXE it works properly, but when run as apache DLL I face session problems. Although I change session.save_path in php.ini to "c:\\apache\\php\\tmp" (also tried "c:\apache\php\tmp") PHP tries to save cookies to /tmp , and for sure it cannot.

I did a session.save_handler = mm  in php.ini, but PHP still tried to save the cookie to /tmp.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-08 13:10 UTC] sniper@php.net
Your php.ini file you are editing isn't read by PHP.
So it's obviously in wrong place. Not a bug.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 20:01:23 2020 UTC