php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12651 Constant 'Broken pipe' errors
Submitted: 2001-08-08 08:38 UTC Modified: 2001-10-28 15:25 UTC
From: tim at timj dot co dot uk Assigned:
Status: Closed Package: Performance problem
PHP Version: 4.0.6 OS: Linux 2.2
Private report: No CVE-ID: None
 [2001-08-08 08:38 UTC] tim at timj dot co dot uk
Since upgrading from 4.0.5 to 4.0.6, I see constant errors in the logs for all my virtual hosts:

(32)Broken pipe: client stopped connection before send mmap completed

Alongside this, I have noticed that frequently when I am using functions on my sites (particularly submitting forms via POST), the connection just times out without a response (although the PHP script HAS executed since the functions it was supposed to perform were done).

I'm not aware of any other configuration changes that might have caused this.  I can't find anything on the lists/bugs about it.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-28 15:25 UTC] tim at timj dot co dot uk
The warning messages are not a bug and are due to Apache LogLevel being changed to 'info'.

The 'hung' connections seem to have eased although not disappeared. Am viewing it as a 'voodoo' (i.e. mystery, hard-to-reproduce) problem.  If someone else has noticed something similar, consider reopening the bug (or creating a new one with specifically that report).
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Feb 21 23:01:26 2019 UTC