php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12594 Unable to load dynamic library
Submitted: 2001-08-06 08:53 UTC Modified: 2003-11-01 13:58 UTC
From: huib at bestia dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.0.6 OS: Windows 2000
Private report: No CVE-ID:
 [2001-08-06 08:53 UTC] huib at bestia dot net
I'm recieve the following error:
Unable to load dynamic library 

for the extensions:
libmcrypt.dll
php_mssql.dll

Some other extensions work fine.
php_mssql.dll is included with php 4.0.6 and libmcrypt is downloaded from a link at php.net

so help me out please,

Regards Huib

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-23 03:05 UTC] sdfsd at dsfd dot csd
If you have any trouble sounding condescending, find a Unix user to show you how it's done.
 [2003-03-16 19:49 UTC] dopeline at hotmail dot com
I'm having the same exact problems except w/ php_domxml.dll, php_xslt.dll, and php_xmlrpc.dll.

In fact, I'm testing this on two separate computers each w/ Win XP Pro and each w/ the exact same installation, IIS, and directory settings. It works perfectly on one and not at all on the other, and I've spent DAYS researching this error.

Replying "RTFM" isn't very helpful.

What would be helpful is explaining why this error is happening, because, as far as I can tell, it's a bug in the windows version of PHP, not a user config error.
 [2003-03-17 02:03 UTC] cg at gordimer dot net
From www.php.net/install.windows:
Some of these extensions need extra DLLs to work. Couple of them can be found in the distribution package [...]
Copy the bundled DLLs from 'DLLs' folder to your Windows PATH [...]

From www.php.net/xslt:
Note to Win32 Users: In order to enable this module on a Windows environment, you must copy sablot.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine.

So - RTFM...

Christoph
 [2004-01-07 04:40 UTC] anon at hotmail dot com
Read the FM and several other postings and it still didn't work - no matter what is in PHP.ini. Finally found that if you put php_mssql.dll in winnt\system32 it works fine.

Lucky there's a few people who aren't condescending out there.
 [2004-07-29 19:56 UTC] destes at ix dot netcom dot com
I had a similar problem with php_mssql.dll .  Turns out the key was to copy the bundled DLL (ntwdblib.dll) to my extension_dir as well as my %SYSTEMROOT%, and i no longer got those notices.  I expect that if I have to load any additional extensions that have bundled DLLs, i'll need to copy them all over god's green earth as well.

As for the "RTFM" folks, I can see this being properly reported as a bug, because the error description should indicate that it's missing a necessary bundled DLL - not just say "unable to load library".  I mean, honestly, the function that claims it's failing is called Unknown(), how much more bug-like can you get?  How about CTFM, Clarify the Fing Messages?
 [2004-07-30 08:21 UTC] norm at whocares dot net
I was also having the same issue on WinXP loading the php_mssql.dll and placing ntwdblib.dll in my extension_dir as well as my %SYSTEMROOT% solved the issue. Thanks for all the help!
 [2004-08-10 23:58 UTC] mofoq at clan-ae dot com
It's not an RTFM issue if the FM gives the wrong answer.
It's not the SYSTEM32 folder but %SYSTEMROOT% (C:\WINDOWS, C:\WINNT, etc.)
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 12:02:07 2014 UTC