php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12459 cvs.php.net gives error
Submitted: 2001-07-29 18:36 UTC Modified: 2001-08-28 04:22 UTC
From: toni dot viemero at iki dot fi Assigned:
Status: Closed Package: Website problem
PHP Version: 4.0.6 OS: Commodore Basic V2.0
Private report: No CVE-ID: None
 [2001-07-29 18:36 UTC] toni dot viemero at iki dot fi
While accessing URL:
http://cvs.php.net/viewcvs.cgi/php4/ChangeLog

I get this:
Python Exception Occurred

Traceback (most recent call last):
  File "/usr/local/www/cvs.php.net/viewcvs.cgi", line 2249, in ?
    main()
  File "/usr/local/www/cvs.php.net/viewcvs.cgi", line 2233, in main
    view_log(request)
  File "/usr/local/www/cvs.php.net/viewcvs.cgi", line 1661, in view_log
    show_revs, rev_map, rev_order, taginfo, rev2tag, \
  File "/usr/local/www/cvs.php.net/viewcvs.cgi", line 1347, in read_log
    head, cur_branch, taginfo, revs = fetch_log(full_name, which_rev)
  File "/usr/local/www/cvs.php.net/viewcvs.cgi", line 1328, in fetch_log
    entry, eof = parse_log_entry(rlog)
  File "/usr/local/www/cvs.php.net/viewcvs.cgi", line 806, in parse_log_entry
    date = int(time.mktime(compat.cvs_strptime(match.group(1)))) - time.timezone
OverflowError: mktime argument out of range

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-01 21:20 UTC] andy@php.net
Reproduced.

I don't know what the problem is, but it is an error :(
 [2001-08-02 03:35 UTC] goba@php.net
You can see the page with Chora :) It works with
PHP and not Python :)) No error on this page...

http://chora.php.net/cvs.php/php4/ChangeLog
 [2001-08-28 04:22 UTC] sander@php.net
I don't think we're supposed to fix bugs in ViewCVS, especially not when we don't use it anymore. Closed.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 22:03:34 2021 UTC