php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #12442 optional linenumbers in highlight_file() (aka show_source() function)
Submitted: 2001-07-27 21:31 UTC Modified: 2016-10-15 23:25 UTC
Votes:6
Avg. Score:3.2 ± 1.2
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: dava at mail dot dk Assigned: nicos (profile)
Status: Closed Package: *General Issues
PHP Version: * OS: *
Private report: No CVE-ID: None
 [2001-07-27 21:31 UTC] dava at mail dot dk
Would be nice with an optional parameter in the show_source funtion, to add linenumbers to the output.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-14 21:07 UTC] brianrene at bitnisse dot dk
Me too! ;)
No really.
It could also be nice with an optional parameter that makes build in functions searchable. So that if i click "strstr" it shows me the function reference from php.net. It could make reading code more painless, guess it's for the really lazy.
 [2002-11-14 21:14 UTC] nicos@php.net
Yes, adding the line numbers and make a link when a PHP functions is on the source can be usefull. 

This is not a bug, but I will take this to php-dev@lists.php.net

Thanks you.
 [2010-12-20 13:29 UTC] jani@php.net
-Package: Feature/Change Request +Package: *General Issues
 [2010-12-20 13:30 UTC] jani@php.net
-Summary: optional linenumbers in show_source +Summary: optional linenumbers in highlight_file() (aka show_source() function)
 [2010-12-20 13:30 UTC] jani@php.net
-Operating System: Any +Operating System: * -PHP Version: 4.3.0 +PHP Version: *
 [2016-10-15 23:25 UTC] kalle@php.net
-Status: Assigned +Status: Closed
 [2016-10-15 23:25 UTC] kalle@php.net
If this is still a desired feature, I propose to raise an RFC, despite this was 15 years ago, the hope never dies!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 19:03:42 2022 UTC