php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12418 ndbm - driver initialization
Submitted: 2001-07-27 06:26 UTC Modified: 2002-05-25 09:02 UTC
From: r dot greil at jusline dot com Assigned:
Status: Not a bug Package: DBM/DBA related
PHP Version: 4.0.6 OS: Suse 7.1
Private report: No CVE-ID: None
 [2001-07-27 06:26 UTC] r dot greil at jusline dot com
$handle = dbm_open("/usr/local/berkeley/nu", "c", "ndbm");


Error: 
  Warning: driver initialization failed     in /usr/local/apache/htdocs/test.php on line 2

My compilation:
  ./configure --with-apache=../apache_1.3.19 --with-ndbm --enable-dba enable-track-vars

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-25 09:02 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2003-03-12 03:54 UTC] b0nks at nerim dot net
The bug is also present in the lastest version
I've tested under Debian Potato 3.0 (kernel 2.2.22) and under Windows XP: Same pb.
"ndbm" is bogus, but the "db2" type seems to be bogus too..
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 07:01:25 2019 UTC