php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12320 Nothing from getenv
Submitted: 2001-07-23 11:36 UTC Modified: 2001-07-23 11:48 UTC
From: stefan at digiconcept dot net Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.6 OS: Win 2K
Private report: No CVE-ID: None
 [2001-07-23 11:36 UTC] stefan at digiconcept dot net
Hi !

The combination of Win2K and IIS5 seams to prevent the nice function getenv to return values. Infos like 'SERVER_SOFTWARE' and so are correctly stored in $HTTP_SERVER_VARS, but why shoul I have 2 access the infos directly via an awfull code like  $x= $GLOBALS[]... if I got an getenv-function ...

regards stefan

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-23 11:48 UTC] hholzgra@php.net
because $HTTP_SERVER_VARS is protable across server APIs
(although not every variable in it is set by every API)
while getenv() is specific to only some of them

remember that gentenv() is a generic environment access
function and as such OS-dependant (on some operating
systems you might even have no such environment at all)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 02:05:56 2022 UTC