php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12211 cURL (OpenSSL) https:// calls do not function
Submitted: 2001-07-17 12:36 UTC Modified: 2001-07-30 18:18 UTC
From: techsupport at momentumgroup dot ca Assigned:
Status: Closed Package: cURL related
PHP Version: 4.0.6 OS: Mandrake/Slackware
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: techsupport at momentumgroup dot ca
New email:
PHP Version: OS:

 

 [2001-07-17 12:36 UTC] techsupport at momentumgroup dot ca
In php4.0.5 cURL w/OpenSSL is fully functional without
problems; although, in php4.0.6, When cURL w/OpenSSL is
installed it all works but not with https:// calls.


-- Errors --
When you use curl_error():
   SSL: Couldn't create a context!

When you use curl_errno():
   27
 Which points explains it as an out of memory error

Although through bash & perl curl works fine with the SSL
pages.  This error has been reported on a variety of sites 
related to cURL but the question have never been responded
to accurately.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-30 18:18 UTC] sterling@php.net
Can you try the latest CVS of PHP and let re-open the bug 
if it still happens.

 [2002-01-17 04:27 UTC] johan at vuurwerk dot nl
I installed the cgi version of php4 (4.1.1) which has curl with ssl support as well. I'm getting the same error, so it doesn't seem to be fixed in new version (or even, every version).
Can someone have a look please? :/
 [2002-01-17 05:41 UTC] me at privacy dot net
Compile PHP without OpenSSL support and CURL https:// calls should work just fine. Seems like there's some unsolved conflicts between OpenSSL and CURL/SSL support.
 [2002-02-21 23:33 UTC] paulm at opentec dot com dot au
I don't know if this is relevant to the original problem but I can cause this error on a server here at will.

I have an installation of Curl 7.8.1, Openssl 0.9.6a, Apache 1.3.20, mod_ssl 2.8.4, php 4.0.6 all running on Solaris.

When I start apache with apachectl startssl the cURL functions work targeting https urls (on other servers).

When I start apache with apachectl start the cURL functions return this error when targeting https urls.

Perhaps that might help at least some of the people experiencing this problem work round it or get it solved.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 06:01:30 2020 UTC