php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12190 Differnt versions (4.0.4 and 4.0.6) have different character case rules
Submitted: 2001-07-16 11:39 UTC Modified: 2001-07-20 08:24 UTC
From: kerrorr at em dot agr dot ca Assigned:
Status: Closed Package: Variables related
PHP Version: 4.0.6 OS: MS NT 4.0 build 1381
Private report: No CVE-ID: None
 [2001-07-16 11:39 UTC] kerrorr at em dot agr dot ca
I am not sure if this is a bug or a feature or what, but for feedback purposes, herewith my tale of sorrow and angst.

We had version 4.0.4 installed on our NT server (4.0 build 1381, Microsoft-IIS/4.0) when it crashed last week (from a surfeit of scratch files in C:/TEMP - we don't know why yet, but we have our suspicions) and this led our sysop to a rebuild of the system.  Whilst doing that, we installed version 4.0.6 using the Win32 installer.  This led to one of our scripts - located in an include file "footer.incl" which takes a META tag defined in the calling PHTML file

     <META NAME="Date_of_last_modification" CONTENT="20010126">

and breaks it apart and displays it.  The script broke under 4.0.6 because the footer.incl file referenced the variable thus:

     $datevar = $datearr["date_of_last_modification"];

Changing that to follow the capitalization of the variable name as in the META statement (i.e. to read Date_of_last_modification) fixed the problem.  However, for some reason, some pages on our server started hanging the server. Apparently, the problem pages do nothing more than display static information and call the same four include files as other similar pages which appeared to work fine.  Since this was the second day of down time, we decided to resolve it by copying version 4.0.4r over the existing installation.  (Why does 4.0.6 have an installer and 4.0.4 didn't?)

That resolved the hanging problem but the date routine broke again.  This time changing the code in the include file back to all lower case worked!?!

We will change all of our meta tags to all lowercase to work around this - which should work. But the question I have is what are the rules of character case?  I've been hunting around in my reference material but haven't found an answer.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-20 07:48 UTC] dbeu@php.net
reproducing code would be helpfull...
 [2001-07-20 08:02 UTC] goba@php.net
this IS NOT a website bug. I can't understand
why kerrorr have submitted this as a website
bug...
 [2001-07-20 08:23 UTC] elixer@php.net
This was my fault.  I rewrote the get_meta_tags function in 4.0.5 and forgot to lowercase the array keys before inserting them.  I recently submitted a patch that corrects this, and it will be available in the next release version.  You can also get the latest development version from CVS.
 [2001-07-20 08:24 UTC] elixer@php.net
Feedback -> Closed
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Mar 26 00:01:27 2019 UTC