php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12179 browscap parsing error
Submitted: 2001-07-15 15:45 UTC Modified: 2001-08-19 09:31 UTC
From: holliwell at gmx dot net Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.5 OS: win
Private report: No CVE-ID: None
 [2001-07-15 15:45 UTC] holliwell at gmx dot net
hi there!
with php.4.0.5 ships a browscap.ini which generates a parse error: PHP:  Error parsing k:\php\browscap\browscap.ini on line 8206
This is line 8206: browser=AE/2.1 (Linux)
and should be:     browser=AE/2.1 Linux 
or any entry making sense. the brackets around Linux are wrong. 
Friedhelm Betz

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-18 22:03 UTC] sniper@php.net
Not PHP problem. You should obtain browscap.ini file
yourself. See this link:

http://www.php.net/manual/en/faq.obtaining.php#AEN62365

--Jani

 [2001-08-19 09:31 UTC] holliwell at gmx dot net
hey Jani,
A browscap.ini is delivered with php 4.0.5.
and therefore it should be a correct version.
It makes no sense to me, to deliver a wrong browsecap.ini and the same time to recommend to obtain it by yourself.
So whats the reason to deliver this wrong browscap with 4.0.5???
Delete it from 4.0.5 or correct it. 
In 4.0.6 there is no browscap -fine.

Friedhelm
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Sep 24 22:05:52 2022 UTC