php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12115 Broken configure: --with-mysql=/opt/mysql
Submitted: 2001-07-12 15:46 UTC Modified: 2001-07-13 12:54 UTC
From: dhoffutt at airmail dot net Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.6 OS: solaris 2.6
Private report: No CVE-ID: None
 [2001-07-12 15:46 UTC] dhoffutt at airmail dot net
When configure PHP with the option "--with-mysql=/path/to/mysql" I get this configuration error: "configure: error: Cannot find mysqlclient library under /opt/local/mysql".

While if I use simply "--with-mysql" I get the echoed warning not to do so when using with other modules such as mod_perl.

Thank you!

./configure \
--with-mysql=/opt/mysql \
--with-apxs=/opt/apache/bin/apxs \
--with-openssl=/opt/openssl \
--with-mm=/usr/local \
--enable-memory-limit

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-12 15:48 UTC] dhoffutt at airmail dot net
oops, i mean the error says:
"configure: error: Cannot find mysqlclient library under /opt/mysql"
 [2001-07-12 15:58 UTC] rasmus@php.net
Well, where is your mysql client library?
 [2001-07-13 11:00 UTC] dhoffutt at airmail dot net
Please close/delete this report.

Permissions culprit on /opt/mysql.

Please forgive the lameness - I shall make a point to have a full night's sleep and double-check the next morning before submitting bug-reports in the future.
 [2001-07-13 12:54 UTC] zak@php.net
User reports that problem was caused by insufficient permissions.
 [2004-05-10 14:22 UTC] aa at aa dot com
What is this...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 04:01:23 2020 UTC