php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #12023 mysql_result moves the data pointer forward one row.
Submitted: 2001-07-10 14:45 UTC Modified: 2016-11-23 13:36 UTC
Votes:6
Avg. Score:2.8 ± 0.4
Reproduced:3 of 4 (75.0%)
Same Version:1 (33.3%)
Same OS:0 (0.0%)
From: john dot hamill at 777design dot com Assigned: cmb (profile)
Status: Closed Package: MySQL related
PHP Version: 4.0.6 OS:
Private report: No CVE-ID: None
 [2001-07-10 14:45 UTC] john dot hamill at 777design dot com
mysql_result moves the data pointer forward one row. i would expect mysql_fetch_row (or similar) to move the row pointer / cursor forward, but not mysql_result.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-10 15:03 UTC] brianlmoon@php.net
not a bug.
 [2001-07-10 15:11 UTC] derick@php.net
Indeed no bug, but a feature/change request

Derick
 [2010-12-17 12:27 UTC] jani@php.net
-Package: Feature/Change Request +Package: MySQL related
 [2016-11-23 13:36 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-11-23 13:36 UTC] cmb@php.net
The MySSQL extension (ext/mysql) has been deprecated as of PHP
5.5.0 and removed as of PHP 7.0.0, so we won't implement any
feature requests anymore.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 09:05:52 2022 UTC