php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11960 I dont know is this an bug?
Submitted: 2001-07-08 10:17 UTC Modified: 2001-07-08 15:38 UTC
From: php at ollysoft dot de Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.0.5 OS: win2000 - IIS5
Private report: No CVE-ID: None
 [2001-07-08 10:17 UTC] php at ollysoft dot de
Please sorry for my bad english... :-)

I use PHP 4.0.5 on Win2000 Server and IIS5.

I have seen this:

one day has 86400 seconds ! 

now this:

$a=getdate(3370 * 86400); //result the 25.3.1979 1:00:00 
and... 
$a=getdate(3371 * 86400); //result the 26.3.1979 2:00:00 

Whay is this so?
Had the 25.3.1979 only 23 hours?
Or think i not korrect?

Please mail me if this is an bug or not.
(php@ollysoft.de)

Thanks for your time
Greetings from germany
Oliver


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-08 15:23 UTC] jimw@php.net
march 25 looks to me like the day that parts of western europe transition to daylight savings time, which would mean that 23 hours is correct.
 [2001-07-08 15:38 UTC] derick@php.net
Not a bug, so bugus.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC