php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11943 some problem with having a "<LINK>" string, it goes downcase..
Submitted: 2001-07-06 21:30 UTC Modified: 2001-07-08 18:40 UTC
From: string at f2s dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.6 OS: gnu/linux 2.4.5
Private report: No CVE-ID: None
 [2001-07-06 21:30 UTC] string at f2s dot com
<?
$a = "LINK";
$b = "<$a>";
echo $b;
?>

the result of this script is: <link>
it changes to downcase, it only output's correct if i take off the <'s or change $a to, for example "LINKA".
i asked some friend of mine with php-4.0.4pl1 on windows and he got the same output.


 './configure' '--with-apache=../apache_1.3.20/' '--enable-magic-quotes' '--enable-calendar' '--enable-ctype' '--with-dom=/usr/local/' '--enable-ftp' '--with-mcrypt' '--with-mhash' '--with-mysql=/usr/local/mysql/' '--enable-trans-sid' '--with-sablot' '--enable-sockets' '--with-zlib' '--enable-bcmath' '--with-db3=/usr/local/BerkeleyDB.3.2/' '--with-pgsql=/usr/local/pgsql/'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-06 23:10 UTC] string at f2s dot com
not a bug at all, it seams that mozilla shows <link> tag's that way.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 10:05:51 2022 UTC