|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11772 configure keeps telling 'This c-client library does not support SSL'
Submitted: 2001-06-28 05:59 UTC Modified: 2001-06-28 15:27 UTC
From: wouter at 2fast dot nl Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.6 OS: Linux 2.2.19 - Slackware 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: wouter at 2fast dot nl
New email:
PHP Version: OS:


 [2001-06-28 05:59 UTC] wouter at 2fast dot nl
Using IMAP-2000c. I tried a lot of options.

cd imap-2000c/
make slx SPECIALAUTHENTICATORS=ssl SSLDIR=/usr/local/ssl
mkdir lib
mkdir include
cp -af c-client/c-client.a ./lib/libc-client.a
cp -af c-client/rfc822.h ./include/
cp -af c-client/mail.h ./include/
cp -af c-client/linkage.h ./include/

PHP-build: (just to check wheter it would work or not)
cd php-4.0.6/
./configure --with-apache=../apache_1.3.20 --with-openssl=/usr/local/ssl --with-imap=../imap-2000c --with-imap-ssl

Also tried --with-imap-ssl=../imap-2000c and --with-imap-ssl=/usr/local/ssl 

Used to use the last one with previous versions of PHP4, and that worked.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-28 15:27 UTC]
This is fixed in CVS. But for 4.0.6, just adding --with-openssl=/usr/local/ssl should help.


PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 29 00:01:28 2024 UTC