php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11772 configure keeps telling 'This c-client library does not support SSL'
Submitted: 2001-06-28 05:59 UTC Modified: 2001-06-28 15:27 UTC
From: wouter at 2fast dot nl Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.6 OS: Linux 2.2.19 - Slackware 7.1
Private report: No CVE-ID: None
 [2001-06-28 05:59 UTC] wouter at 2fast dot nl
Using IMAP-2000c. I tried a lot of options.

IMAP-build:
cd imap-2000c/
make slx SPECIALAUTHENTICATORS=ssl SSLDIR=/usr/local/ssl
mkdir lib
mkdir include
cp -af c-client/c-client.a ./lib/libc-client.a
cp -af c-client/rfc822.h ./include/
cp -af c-client/mail.h ./include/
cp -af c-client/linkage.h ./include/

PHP-build: (just to check wheter it would work or not)
cd php-4.0.6/
./configure --with-apache=../apache_1.3.20 --with-openssl=/usr/local/ssl --with-imap=../imap-2000c --with-imap-ssl

Also tried --with-imap-ssl=../imap-2000c and --with-imap-ssl=/usr/local/ssl 

Used to use the last one with previous versions of PHP4, and that worked.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-28 15:27 UTC] sniper@php.net
This is fixed in CVS. But for 4.0.6, just adding --with-openssl=/usr/local/ssl should help.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 00:05:44 2022 UTC