php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11743 Escaping quotes gets out of hand
Submitted: 2001-06-27 11:12 UTC Modified: 2001-06-27 13:21 UTC
From: cheapsalsa at yahoo dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.0.6 OS: Red Hat Linux 7.0 Standard
Private report: No CVE-ID: None
 [2001-06-27 11:12 UTC] cheapsalsa at yahoo dot com
I have created a news program for my website using PHP
4.0.6.  When I need to edit the news, the program rewrites
the whole news file, whether a news story got edited or not.
 Sometimes I have to include quotes like ' or ".  The first
time I post the news they look like \' \" (with one
backslash).  After I edited the news a couple of times it
can get out of hand, and the quotes look like \\\\\\\\\\\\'
or \\\\\\\\\\\\" . This looks really bad.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-27 13:21 UTC] sniper@php.net
Check your php.ini settings and set magic_quotes=off
Not a bug.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 18:01:27 2019 UTC