php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11690 apxs does not support -S
Submitted: 2001-06-26 05:24 UTC Modified: 2002-04-10 18:39 UTC
From: glen at designsolution dot co dot uk Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.6 OS: Cobalt OS 5.0 (RaQ3)
Private report: No CVE-ID: None
 [2001-06-26 05:24 UTC] glen at designsolution dot co dot uk
I currently have PHP4.0.4pl1 running fine on a Cobalt RaQ3 
machine, and I attempted to upgrade to version 4.0.6.

The configure and make went okay with no errors reported, 
but 'make install' fails with the following error:

---
Making install in .
make[1]: Entering directory 
`/home/sites/home/users/admin/php-4.0.6'
/home/sites/home/users/admin/php-4.0.6/build/shtool mkdir 
-p "/usr/lib/apache" && /usr/sbin/apxs -S 
LIBEXECDIR="/usr/lib/apache" -i -a -n php4 libs/libphp4.so
apxs:Error: Unknown option: S
Usage: apxs -g -n <modname>
       apxs -q <query> ...
       apxs -c [-o <dsofile>] [-D <name>[=<value>]] [-I 
<incdir>]
               [-L <libdir>] [-l <libname>] [-Wc,<flags>] 
[-Wl,<flags>]
               <files> ...
       apxs -i [-a] [-A] [-n <modname>] <dsofile> ...
make[1]: *** [install-sapi] Error 1
make[1]: Leaving directory 
`/home/sites/home/users/admin/php-4.0.6'
make: *** [install-recursive] Error 1

---

It seems the PHP install is trying to install the DSO 
module with an option that apxs doesn't support ( -S ).  
The RaQ3 is running Apache version 1.3.6.

Regards,

Glen Scott

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-26 10:21 UTC] derick@php.net
Duplicate of 11647
 [2002-04-10 18:39 UTC] sniper@php.net
this was fixed a while ago. (4.1.0 iirc)

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 16:03:56 2022 UTC