php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11677 system(), "Access is denied"
Submitted: 2001-06-25 20:11 UTC Modified: 2001-06-26 06:31 UTC
From: jxu158 at yahoo dot com Assigned:
Status: Not a bug Package: Program Execution
PHP Version: 4.0.6 OS: WinNT 4.0
Private report: No CVE-ID: None
 [2001-06-25 20:11 UTC] jxu158 at yahoo dot com
I try to use system() to run a batch file which sitting on a mapped network drive like this :
  system("e:\\tmp\file.bat")
but it gives me "Access is denied".

I can run this batch file in "Command Prompt" window successfully. When system() works with the files sitting on server machine, no problem at all.

I will appreciate if you can help me this. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-26 06:30 UTC] sniper@php.net
I don't know Winnt at all, but on unices, the user
the webserver runs as needs to be able to run the files.

 [2001-06-26 06:31 UTC] zak@php.net
Sorry - this really is not a bug (or at least is very likely not a bug)

Please send your question to the PHP Windows mailing list instead. php-windows@lists.php.net (Subscribe at php-windows-subscribe@lists.php.net)


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 10:01:23 2020 UTC