php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11607 uploads with type=>
Submitted: 2001-06-21 11:47 UTC Modified: 2001-06-22 08:53 UTC
From: lance_laureys at 3com dot com Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.0.5 OS: bsdi 4.x
Private report: No CVE-ID: None
 [2001-06-21 11:47 UTC] lance_laureys at 3com dot com
Current version of PHP 4.0.5

Doing the default HTTP post uploads right from the documentation I am seeing a problem where if I upload a text file, word document it works fine and reports the file size back. 
Array ( [userfile] => Array ( [name] => Computer Features.htm [type] => text/html [tmp_name] => /var/tmp//php015005 [size] => 1350 ) ) 

Array ( [userfile] => Array ( [name] => catmatrix.jpg [type] => image/pjpeg [tmp_name] => /var/tmp//php015005 [size] => 27094 ) ) 

When doing .pdf, .exe .wab (other's im not sure of)

Array ( [userfile] => Array ( [name] => ClientReferenceJS13.pdf [type] => application/pdf [tmp_name] => none [size] => 0 ) ) 
Array ( [userfile] => Array ( [name] => dMC-r3.exe [type] => application/octet-stream [tmp_name] => none [size] => 0 ) ) 

There not being uploaded althought it seems they are by the httpd processing spinning up.

Any ideas what would cause this?

L

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-21 18:17 UTC] sniper@php.net
With which browser/version and on which OS does this happen?
This works for me with ANY file with NS 4.77 just fine.

--Jani

 [2001-06-22 08:53 UTC] sniper@php.net
User feedback:
--------------
Okay, last email was incomplete but I did get better results on this.

Here is what I found but I am not sure why it's doing it.

Netscape 4.08 works (Jani tested with 4.77)
IE 5.5 works
IE 6.0 PP does not work. (any ideas on how to debug this one?)
--------------

Report it to Microsoft. Obviously they have again broke
the standards. Or it's buggy some other way. But in any
case this is NOT PHP problem. 

But you might wanna try PHP 4.0.6 (should be released today)
as there was some fixes for Opera's different behaviour in it. Maybe the IE 6.0 is doing something similar?

Uploading works for me now with Mozilla/Opera/NS/IE 5.5
(I haven't tested IE 6 yet)

--Jani

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jun 14 19:01:23 2021 UTC