php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11584 Apache will not start with PayFlow Pro SDK
Submitted: 2001-06-20 13:15 UTC Modified: 2001-06-20 13:18 UTC
From: jeanluc at columbia dot edu Assigned:
Status: Closed Package: Verisign Payflow Pro related
PHP Version: 4.0 Latest CVS (2001-06-20) OS: Redhat Linux 6.2 (2.2.14)
Private report: No CVE-ID: None
 [2001-06-20 13:15 UTC] jeanluc at columbia dot edu

[ Payflow Pro ] -------------------------------------------

Version 3.0

libpfpro.so in /usr/local/lib
pfpro.h in /usr/local/include

[ PHP Configure ]------------------------------------------

php-4.0.6RC4

'./configure' '--with-apache=/usr/src/apache_1.3.0/' '--with-mysql=/usr/local/mysql/' '--enable-debug' '--enable-track-vars' '--with-sybase-ct=/opt/sybase/' '--with-pfpro'

[ Apache Configuration ] ----------------------------------

version -> Apache/1.3.0 Ben-SSL/1.19

from ./src/Configuration:

AddModule modules/ssl/apache_ssl.a
AddModule modules/php4/libphp4.a

[ GDB Backtrace ]------------------------------------------

(gdb) run -X
Starting program: /usr/src/apache_1.3.0/src/httpd -X
Skip first time initialisation
Reading certificate and key for server www.college.columbia.edu:443

Program received signal SIGSEGV, Segmentation fault.
0x4009b00c in pfproVersion () from /usr/local/lib/libpfpro.so

(gdb) bt
#0  0x4009b00c in pfproVersion () from /usr/local/lib/libpfpro.so
#1  0x8141061 in InitSSLServer ()
#2  0x814534f in ap_init_modules ()
#3  0x814b411 in standalone_main ()
#4  0x814b949 in main ()
#5  0x4022a9cb in __libc_start_main (main=0x814b760 <main>, argc=2, argv=0xbffffb34, 
    init=0x806437c <_init>, fini=0x8167c1c <_fini>, rtld_fini=0x4000ae60 <_dl_fini>, 
    stack_end=0xbffffb2c) at ../sysdeps/generic/libc-start.c:92
(gdb) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-20 13:18 UTC] sniper@php.net
This is not PHP bug. The PFpro libs have their own
ssl libs in them which clash with the ones within
your Apache. So report this to the PFpro people.

 [2003-08-05 10:42 UTC] bduell at ncacasi dot org
I have verified, through VeriSign, that the SDK of PayflowPro (currently, v. 3.06) is statically linked against the openssl libraries.

They have no plans on changing this design, therefor we will be changing payment processors.

Good luck!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 16:03:40 2021 UTC