php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11581 Call to undefined function: socket() but compiled with --enable-sockets
Submitted: 2001-06-20 09:43 UTC Modified: 2001-06-20 12:43 UTC
From: lukas dot beeler at projectdream dot org Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.0 Latest CVS (2001-06-20) OS: Slackware-current / Kernel 2.4.5
Private report: No CVE-ID: None
 [2001-06-20 09:43 UTC] lukas dot beeler at projectdream dot org
iam using the latest CVS version of php 4.0.7-devel, just downloaded and compiled today. i've compiled it with:
Configure Command  './configure' '--with-imap=../../imap-2001.BETA.SNAP-0105220031' '--with-pcntl' '--with-mysql=/usr/mysql' '--with-zlib-dir' '--with-ftp' '--with-gd--with-jpeg' '--enable-versioning' '--enable-track-vars=yes' '--enable-url-includes' '--enable-sysvshm=yes' '--enable-sysvsem=yes' '--with-config-file-path=/etc' '--enable-sockets' '--with-openssl' '--with-xpm' '--enable-pcntl' 
now my problem is, that if i execute the sample script for the socket() function, it reports:
<b>Fatal error</b>:  Call to undefined function:  socket() in <b>ficken.php</b> on line <b>10</b><br>

Did i configure something wrong, (standard php.ini) or is this really a bug ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-20 12:43 UTC] sniper@php.net
No, you propably got it just right. The problem is,
that in the latest CVS the socket functions are renamed.
Try checking the ext/sockets/php_sockets.h for the correct func names. There propably won't be 4.0.7 but 4.1.0 next.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 12:01:25 2020 UTC