php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11495 error: Mysql_connect() doesn't exist.
Submitted: 2001-06-14 17:05 UTC Modified: 2001-06-14 20:12 UTC
From: jonathonfitch at hotmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.5 OS: NT
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jonathonfitch at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-06-14 17:05 UTC] jonathonfitch at hotmail dot com
This is the error I'm getting:

Fatal error: Call to unsupported or undefined function mysql_connect() in C:\Inetpub\wwwroot\test.php3 on line 3

This is the script:

<?

    $link = mysql_connect ("localhost", "username", "secret")
        or die ("Could not connect");
    print ("Connected successfully");
    mysql_close ($link);

?>

I've tried both PHP 3 and PHP 4, both give me this error....

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-14 20:12 UTC] sniper@php.net
Your system must be severely fucked up because in the
precompiled binaries provided at php.net the mysql
support is builtin..ie. you can NOT be without mysql_connect()..

Follow the instructions given in install.txt and all
should be fine. 

Anyway, this is NOT a bug in PHP but you have done something
wrong.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 16:05:48 2023 UTC