php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1145 cannot compile with --with-ldap using the Solaris7 bundled ldap-libs/header
Submitted: 1999-02-13 18:06 UTC Modified: 2007-10-06 02:30 UTC
From: rk at netuse dot de Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 3.0.6 OS: Solaris 7 (sparc)
Private report: No CVE-ID: None
 [1999-02-13 18:06 UTC] rk at netuse dot de
Solaris 7 (SunOS 5.7) comes with ldap-libs (libldap.so) and
the needed headers (ldap.h, lber.h) in /usr/lib and /usr/include.
So using --with-ldap should work fine. BUT:
$ gcc --version
egcs-2.91.57
$ make
gcc -g -O2 -O2   -I. -I.         -I/opt/mysql/include/mysql      -I/usr/local/ldap/include    -I/home/rk/sendmail/imap-4.5.BETA/c-client/include/    -c functions/ldap.c -o functions/ldap.o
functions/ldap.c: In function `php3_ldap_bind':
functions/ldap.c:534: dereferencing pointer to incomplete type
functions/ldap.c: In function `php3_ldap_do_search':
functions/ldap.c:650: dereferencing pointer to incomplete type
functions/ldap.c: In function `php3_ldap_get_values':
functions/ldap.c:1027: dereferencing pointer to incomplete type
*** Error code 1
make: Fatal error: Command failed for target `functions/ldap.o'

I also do not have a /usr/local/ldap/include !

Somehow the error looks like the one you get, if you try
to compile sendmail-8.9.1 with MAPLDAP support.
In sendmail 8.9.2 things in the maps.c (sendmail tree)
have changed, so that this works now. As far as I understand
that has to do with the right settings of sone #define
values. You may diff those two trees ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-12-13 15:53 UTC] joey at cvs dot php dot net
Is this bug still there?
 [2000-07-19 12:36 UTC] hholzgra at cvs dot php dot net
yes, it is ... :(
 [2002-06-16 08:28 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC