php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11442 Random "Warnig: Failed opening" on any php file
Submitted: 2001-06-12 14:49 UTC Modified: 2003-07-03 13:46 UTC
Votes:9
Avg. Score:4.8 ± 0.4
Reproduced:9 of 9 (100.0%)
Same Version:3 (33.3%)
Same OS:5 (55.6%)
From: aferriz at yahoo dot com Assigned:
Status: Closed Package: iPlanet related
PHP Version: 4.3.2 OS: Solaris 7
Private report: No CVE-ID: None
 [2001-06-12 14:49 UTC] aferriz at yahoo dot com
This bug is the same as #7163 but it was closed because no feedback. Im having the same problem here in different machines with Solaris 7 and iPlanet-WebServer-Enterprise/4.1SP2.
I?ve had this problem with php 4.0.4pl1, 4.0.5 and all the snaps, and many different build options.
It?s a heavy load web server, and it works fine for about 10 minutes, but then it randomly displays the "Failed opening ... in Unknown on line 0" for every php file on the web server.
I compiled php with gcc 2.8.1 to gcc 2.95.3 and its always the same.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-13 16:37 UTC] cardinal@php.net
This tends to be an issue with file permissions.  Check that the user your web server is running as has read access to the files in question
 [2001-06-13 17:48 UTC] aferriz at yahoo dot com
I?ve checked and the user of the web server is the owner of all the files in the html document root.
 [2002-03-28 07:46 UTC] xt5000 at myrealbox dot com
The version we are using is 4.1  Our problem is pretty much the same except we end up getting 404 pages due to the configuration.  We have 404 configured to dish 404's if there is a failure.  It runs fine for 6-10 minutes, but undera load it fails.
 [2002-08-17 01:39 UTC] kalowsky@php.net
Is this still a valid bug with the newer releases?

Also updating the version to a reported 4.1
 [2002-08-23 07:10 UTC] groehrbein at bigfoot dot com
I have same problem after using virtual web servers.
But the problem does not appear random it apperas since I installed the virtual web servers.

Operating System is Solaris 5.7
HTTP Server ist iPlanet 4
PHP Version is 4.0.4 (because LDAP support does not work with iPlanet in other PHP Releases under Solaris)
 [2002-08-29 10:13 UTC] migcas at eltiempo dot com dot co
I'm experimenting exactly the same problem reported by aferruz@yahoo.com, but I'm using PHP 4.1.2 and Iplanet WebServer 4.1sp9 over sparc solaris 8. This is a heavy load web server.
 [2002-09-05 10:10 UTC] mustafa at xxx dot lt
I have the same problem under Debian/apache/PHP 4.2.2
Warning: Failed opening '/var/www/HTTP/index.php' for inclusion ..........
I have read that include_path in php.ini should be set to ".", then that include_path shoul be commented, but nothing helps...
 [2002-09-09 10:36 UTC] kalowsky@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip

I know I've said it before, but there was a bug fix in 4.2.3 that dealt with a timing issue.  Wondering if this helps any for your systems.
 [2002-09-26 20:04 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-12-04 09:38 UTC] jari at utu dot fi
We are running PHP 4.2.3 with iPlanet Enterprise Web Server 6.0 SP4. We have the same php module used by several server instances, one of which works perfectly. The php module in other instances seems to freeze randomly: one minute the page works, next all we have is an empty page containing nothing more than <html><body></body></html> tags.
 [2003-01-10 16:19 UTC] solarstring at yahoo dot com
I have installed the latest version of php (4.3.2 - Jan2) on Solaris 5.8 , IPlanet, and can verify this problem still exists.  In fact, a different server with the same build configuration of php, and same versions of Netscape/Iplanet, php works fine...
PHP Version 4.3.0 

System  SunOS wildcat 5.8 Generic_108528-17 sun4u  
Build Date  Jan 2 2003 16:57:46  
Configure Command  './configure' '--enable-libgcc' '--prefix=/usr/local' '--with-oci8=/u/ora/app/oracle/product/9.0.1' '--with-nsapi=/u/web/netscape/iplanet/' '--enable-sysvsem' '--enable-discard-path' '--enable-magic-quotes' '--enable-memory-limit' '--enable-versioning' '--enable-track-vars' '--enable-trans-sid' '--enable-sigchild'  
Server API  NSAPI  
Virtual Directory Support  enabled  
Configuration File (php.ini) Path  /usr/local/lib/php.ini  
PHP API  20020918  
PHP Extension  20020429  
Zend Extension  20021010  
Debug Build  no  
Thread Safety  enabled  
Registered PHP Streams  php, http, ftp  


Have there been any bug patches explicitly related to this?
 [2003-04-02 08:02 UTC] koralix at konixx dot cjb dot net
mustafa at xxx dot lt 
----------
I have read that include_path in php.ini should be set to ".", then that
include_path shoul be commented, but nothing helps...

that helped in my case! WindowsME!!!! thanks a lot!
 [2003-05-16 03:52 UTC] magnus@php.net
Closing this one now after the recent fixes for broken 
Solaris systems. Reopen it if it doesn't work with a snap 
from http://snaps.php.net or the upcomming 4.3.2 release. 
 [2003-07-02 11:33 UTC] aferriz at yahoo dot com
I've just installed another Solaris 7 server with iPlanet-WebServer-Enterprise/PHP 4.3.2 and I have the same problem "Failed opening ..." at random points, again, this is a hi-load server.
I'll try to install PHP 5.0 Beta just for testing.
 [2003-07-02 21:42 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 [2003-07-03 13:46 UTC] aferriz at yahoo dot com
Ok, its been fixed in 4.3.2.
Sorry for my last post, in my last installation, I was using a wrong path and I ended up using 4.3.1 shared library, 4.3.2 works fine now.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 20:01:30 2024 UTC