php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11219 include_path does not function correctly when multiple paths are specified
Submitted: 2001-05-31 12:56 UTC Modified: 2001-05-31 17:19 UTC
From: WPinegar at healthtech dot net Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.5 OS: Windows 2000
Private report: No CVE-ID: None
 [2001-05-31 12:56 UTC] WPinegar at healthtech dot net
When running PHP 4.0.5 in CGI on Windows 2000 I've noticed that setting the php.ini's include_path to "include_path = .;C:\Inetpub\Include" does not work.  The include
path only results in the first path being searched.  Everything after the first ";" is ignored.

Also, when I run the phpinfo() function it shows that the include_path is simply "." instead of showing both items in the include path. 

Can someone correct this and e-mail me the fix?  Thanks!

[2001-05-30 22:18:05] sniper@php.net

Put your php.ini into place where it actually gets read.
And ask further support questions on some appropriate mailing list. This is not a bug.

[2001-05-31 09:27:17] WPinegar@healthtech.net

The php.ini file is in my WINDOWS subdirectory and is indeed being picked up by PHP.

If I change the include_path to C:\Inetpub\Include;. only the first part of the path is searched (C:\Inetpub\Include)the current directory is no longer be searched.

When I execute phpinfo() it only show the include_path as simply "C:\Inetpub\Include" instead of showing both items in the include path.

This is a bug.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-31 17:11 UTC] sniper@php.net
You almost got me fooled. :)
This indeed is NOT bug. But more a misunderstanding.
; in php.ini is considered as comment. Anything after
that is not taken into account. So this won't work:

include_path=.;c:\inetpub\include

but this will

include_path=".;c:\inetpub\include"

I added examples to the php.ini-dist now so we don't 
get more bug reports about this anymore.

--Jani

 [2001-05-31 17:19 UTC] WPinegar at healthtech dot net
Thanks!  Much appreciated.  Putting quotes around it does indeed fix the problem!

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 21:03:45 2023 UTC