php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11093 Apache crashes when output buffering is used and fatal errors occure
Submitted: 2001-05-24 13:05 UTC Modified: 2001-12-12 05:45 UTC
From: mail at customdesign dot de Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.5 OS: Win32
Private report: No CVE-ID: None
 [2001-05-24 13:05 UTC] mail at customdesign dot de
I use Output Buffering for some php scripts and develop on a Win32 system. One time i tried to call a not existing function -> Apache crashes when i try to load the php document in a browser.

I don't have made a UNIX test right now, but on Win32
(Win 95/98/ME) Apache/PHP4TS.DLL crashes when i produce fatal errors (like the function call). Parse errors and others are displayed like normal. If i disable the output functions, the fatal error message is displayed like normal.


AUTO PREPEND FILE
-----------------
<?
ob_start();
?>

Resquested document: (by example: index.php)
---------------------------------------------
<?
undefinied_function(); // this function does not exist
?>


AUTO APPEND FILE
----------------
<?
$SITE_CONTENTS=ob_get_contents();
ob_end_clean();
print $SITE_CONTENTS;
?>

Additional Enviroment Info:
---------------------------
OS: WinME,Win98 SE
PHP: 4.05 running as Apache module
Loaded PHP Extensions: zlib,gd
Apache: Version 1.3.12


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-12 04:28 UTC] yohgaki@php.net
Does this happen with 4.1.0?
 [2001-12-12 05:45 UTC] yohgaki@php.net
User reported, he/she is no longer using Windows98/ME.
Cannot reproduce under Linux with 4.1.0, so closed.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 08:01:26 2020 UTC