php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #11070 '@' does not turn off error checking in foreach()
Submitted: 2001-05-23 18:47 UTC Modified: 2001-08-28 04:19 UTC
From: lee at mediawaveonline dot com Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.5 OS: linux
Private report: No CVE-ID: None
 [2001-05-23 18:47 UTC] lee at mediawaveonline dot com
it would be nice to see the '@' turn off error reporting on the foreach() command. ie.

<?php
  foreach($test as $pos => $val)
  {

  }
?>
gives an error because $test is not set.

<?php
  foreach(@$test as $pos => $val)
  {

  }
?>
gives an error because its the wrong data type.

<?php
  @foreach($test as $pos => $val)
  {

  }
?>
gives a syntax error. it would be nice if this last command worked :)

  Chris Lee
  lee@mediawaveonline.com


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-23 18:52 UTC] cnewbill@php.net
Use....

if (is_array($a))
    foreach ($a as $key => $val) {
        /* Do something */
    }

....until it is added, which it may not be.

-Chris
 [2001-08-28 04:19 UTC] sander@php.net
Duplicate of 6118.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC