|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11055 segmentation fauld & core dump during make
Submitted: 2001-05-23 11:42 UTC Modified: 2001-05-27 19:42 UTC
From: louigi600 at gsmbox dot it Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.0.5 OS: linux 2.2.14 (RH 6.2)
Private report: No CVE-ID: None
 [2001-05-23 11:42 UTC] louigi600 at gsmbox dot it
downloaded free sybase-ct libs from link in faq from php site.
unpacked in /sybase-ct
fixed /etc/ & ran ldconfig

then tried to compile php with sybase-ct support (in order to access MSSQL server) as a DSO module:

[root@linux php-4.0.5]# ./configure --with-mysql --with-apxs --enable-sockets --with-oracle=/mnt/ora_syb/ora/app/oracle/product/8.0.5 --with-sybase-ct=/sybase-ct

went fine then ran:
[root@linux php-4.0.5]# make

got the following error:

make[1]: Entering directory `/mnt/ora_syb/php-4.0.5'
/bin/sh /mnt/ora_syb/php-4.0.5/libtool --silent --mode=link gcc  -I. -I/mnt/ora_syb/php-4.0.5/ -I/mnt/ora_syb/php-4.0.5/main -I/mnt/ora_syb/php-4.0.5 -I/usr/include/apache -I/mnt/ora_syb/php-4.0.5/Zend -I/mnt/ora_syb/php-4.0.5/ext/mysql/libmysql -I/mnt/ora_syb/ora/app/oracle/product/8.0.5/rdbms/demo -I/mnt/ora_syb/ora/app/oracle/product/8.0.5/network/public -I/mnt/ora_syb/ora/app/oracle/product/8.0.5/plsql/public -I/sybase-ct/include -I/mnt/ora_syb/php-4.0.5/ext/xml/expat/xmltok -I/mnt/ora_syb/php-4.0.5/ext/xml/expat/xmlparse -I/mnt/ora_syb/php-4.0.5/TSRM  -DLINUX=2 -DEAPI -DUSE_EXPAT -DSUPPORT_UTF8 -DXML_BYTE_ORDER=12 -g -O2   -o -rpath /mnt/ora_syb/php-4.0.5/libs -avoid-version -L/mnt/ora_syb/ora/app/oracle/product/8.0.5/lib -L/sybase-ct/lib  -R /mnt/ora_syb/ora/app/oracle/product/8.0.5/lib -R /sybase-ct/lib stub.lo  Zend/ sapi/apache/ main/ regex/ ext/mysql/ ext/oracle/ ext/pcre/ ext/posix/ ext/session/ ext/sockets/ ext/standard/ ext/sybase_ct/ ext/xml/ TSRM/ -lpam -ldl -linsck -lsybtcl -lintl -lcomn -lct -lcs -lclntsh -lpsa -lcore4 -lnlsrtl3 -lm -lnsl -lresolv -lm -ldl -lcrypt -lnsl -lresolv
collect2: ld terminated with signal 11 [Segmentation fault], core dumped
/sybase-ct/lib/libct.a(ctconpr.o)(.text+0x5ac): undefined reference to `comn_loc_copy'
make[1]: *** [] Error 1
make[1]: Leaving directory `/mnt/ora_syb/php-4.0.5'
make: *** [all-recursive] Error 1

previous run witout sybase-ct support went fine!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-23 14:19 UTC] louigi600 at gsmbox dot it
someone suggests to try:
php 4.0.6rc1 from  or try a
4.0.7-dev snapshot from

But as the problem comes from:
/sybase-ct/lib/libct.a(ctconpr.o)(.text+0x5ac): undefined reference to `comn_loc_copy'

I suspect that this is not a solution to the problem, as make process ends up with the exact same error with bothe newer versions suggested.

Any other ideas ?
 [2001-05-27 19:42 UTC]
Can't reproduce. There is most likely something
wrong with your memory or your linker or compiler.


PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 09:01:28 2024 UTC