php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11042 magic_quotes_runtime() value not reality
Submitted: 2001-05-23 01:34 UTC Modified: 2001-12-14 14:56 UTC
From: phil at buxtech dot com Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: 4.0.5 OS: Solaris 2.x / 7 / 7
Private report: No CVE-ID: None
 [2001-05-23 01:34 UTC] phil at buxtech dot com
This issue has been duplicated in 4.0.5 and 4.0.4pl1.  We've not tried to go further back.

We have several small HTML forms applications that make use of PHPLIB's template feature.  Sometimes when HTML is generated, things are fine.  Other times, it's all horked up because there are back-slashes in the HTML output.  We've tracked the root cause of this issue to PHP's setting of magic_quotes_runtime().

We have it configured for "Off" but sometimes this function value is 1, other times it is 0.  We can insert:

print "magic rt = " . magic_quotes_runtime() . "<br>";

into our application ... sometimes we'll see that the value is 1, other times 0.  Just clicking refresh seems to yield a seemly random result.

We've worked around this issue by adding

ini_set("magic_quotes_runtime", 0);

at the top of our code ... but this behavior can't be expected.  Or are we missing something?

Thanx for your time in looking into this -- you have a great environment for web programming.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-14 14:56 UTC] yohgaki@php.net
magic_quotes_runtime() does not exit.
Use set/set_magic_quotes_runtime().



 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Dec 12 10:01:25 2018 UTC