php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11039 Netscape Server 3.6 / Solaris 8 problems...
Submitted: 2001-05-22 22:29 UTC Modified: 2002-09-18 01:00 UTC
From: jimf at bismark dot com Assigned:
Status: No Feedback Package: iPlanet related
PHP Version: 4.0.5 OS: Solaris 8
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2001-05-22 22:29 UTC] jimf at bismark dot com
I am running a Solaris (sparc) 8 box with Netscape Enterprise Server 3.6.
The compile of PHP goes well. I used 
-------
./configure --with-mysql=/usr/local/mysql --with-nsapi=/mypath/netscape/suitespot/ --enable-track-vars --enable-libgcc 
make 
make install
-------
I then modified my start script for the server I am running (adding lib paths), and finally modified my obj.conf adding all the information needed as stated in "nsapi-readme.txt".
However, my server will refuse to startup when this init line is added to my obj.conf
------
Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="/usr/local/netscape/suitespot/bin/libphp4.so"
------
When the start script is executed it simply returns back with a command promt, no error.

If I comment out this newly added init, everything works (whithout PHP support of course).

When I install PHP with the above config options on a Solaris 2.6 machine with Netscape Enterprise 3.6, everything runs great.  So I do not know where the problem is coming from, Solaris 8 or Netscape Server 3.6.

Any insight would be greatly appreciated.

James
      

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-17 01:36 UTC] kalowsky@php.net
The problem probably comes from Solaris 8, which I don't think was really tested at the time.  Do please try a newer version and tell us if this is happening to you still.  There have been drastic changes between the release versions since this bug has been submitted.
 [2002-09-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 17:03:35 2021 UTC