php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11028 ip2long use now unsigned integer and long2ip doesnt work
Submitted: 2001-05-22 15:29 UTC Modified: 2001-09-09 07:42 UTC
From: alberty at neptunlabs dot de Assigned: derick (profile)
Status: Closed Package: Network related
PHP Version: 4.0 Latest CVS (2001-05-22) OS: i686-pc-linux-gnu
Private report: No CVE-ID: None
 [2001-05-22 15:29 UTC] alberty at neptunlabs dot de
ip2long puts under 4.0.6RC1 unsigned integers.
now long2ip doesnt work.

./configure \
--with-apxs=/usr/local/apache/current/bin/apxs \
--with-config-file-path=/etc \
--with-openssl=/usr/local/openssl/current \
--enable-sigchild \
--enable-thread-safety \
--disable-short-tags \
--with-bz2 \
--with-curl=/usr/local/curl/current \
--enable-ftp \
--with-mhash=/usr/local/mhash/current \
--with-mysql=/usr/local/mysql/current \
--with-mm=../mm-1.1.3 \
--enable-trans-sid \
--enable-sockets \
--enable-sysvsem \
--enable-sysvshm \
--with-zlib \
--with-jpeg-dir=/usr \
--with-png-dir=/usr/local \
--enable-inline-optimization \
--enable-memory-limit \
--enable-shmop \
--with-mcrypt=/usr/local/libmcrypt/current \
--with-recode \
--disable-debug \
--with-gd

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-22 15:39 UTC] derick@php.net
Ok, will see if we can really fix this now.

Derick
 [2001-05-22 15:42 UTC] derick@php.net
Can you please post a short script which shows the problem?

Derick
 [2001-05-23 02:50 UTC] derick@php.net
User reports:

Hi Derick.

here is a short code script fpr ip2long().
<?php
$tmp1="192.168.0.10";
$tmp2=ip2long($tmp1);
$tmp3=long2ip($tmp2);
echo "$tmp1 - $tmp2 - $tmp3";
?>

Under php4.0.5 $tmp2 results: -1062731766
with the same compiler options
under php4.0.6RC1 :  3232235530
 [2001-09-09 07:42 UTC] derick@php.net
Not a bug at all, this is the correct way to do it:
<?php
$tmp1="192.168.0.10";
$tmp2=ip2long($tmp1);
$tmp3=long2ip($tmp2);
printf ("%s - %u - %s", $tmp1, $tmp2, $tmp3);
?>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 13:04:08 2021 UTC