php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11014 Can't build PDFlib with PHP successfully
Submitted: 2001-05-22 07:07 UTC Modified: 2001-05-23 10:11 UTC
From: leo at sayya dot org Assigned:
Status: Not a bug Package: PDF related
PHP Version: 4.0.5 OS: Linux 2.2.14 i586
Private report: No CVE-ID: None
 [2001-05-22 07:07 UTC] leo at sayya dot org
Hi!
I'm install PDFlib rpm files (pdflib-4.0.1-1,pdflib-tcl-4.0.1-1,pdflib-devel-4.0.1-1).

My PHP configure lines:
./configure --with-mysql=/usr/local/mysql --with-apache=/usr/src/apache_1.3.19 --enable-ftp --enable-discard-path --with-pdflib=/usr/lib --with-gd

That's OK! System don't response any error messages!
Then, I compile PHP and Apache source code.

No any error messages during compiling.

But.. It still can't use any pdf functions like pdf_open().
My Linux box will tall me "Fatal error: Call to undefined function.."

I tried to compile PHP with PDFlib again,
and saw some information:

(1)
checking whether to include PDFlib support... yes

(2)
creating ext/ftp/Makefile
creating ext/gd/Makefile
creating ext/mysql/Makefile
creating ext/pcre/Makefile
creating ext/pcre/pcrelib/Makefile
creating ext/posix/Makefile
creating ext/session/Makefile
creating ext/standard/Makefile
creating ext/xml/Makefile
creating ext/xml/expat/Makefile
creating ext/xml/expat/xmlparse/Makefile
creating ext/xml/expat/xmltok/Makefile

==> It did not create ext/pdf/Makefile!


P.S: Before compile PHP, I have updated the PHP source sode from PHP and Zend CVS.
My commands are:
==> # cvs -d :pserver:cvsread@cvs.php.net:/repository co php4
==> cd php4
==> # cvs -d :pserver:cvsread@cvs.zend.com:/repository co Zend TSRM
==> # cp -r * /usr/src/php-4.0.5/

Is this a bug at php-4.0.5?
How can I do that you recommend?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-22 09:02 UTC] derick@php.net
When did you checkout the PHP (and Zend/TSRM) tree from the CVS?

Derick
 [2001-05-22 12:26 UTC] leo at sayya dot org
Hi!
I'm install PDFlib rpm files (pdflib-4.0.1-1,pdflib-tcl-4.0.1-1,pdflib-devel-4.0.1-1).

My PHP configure lines:
./configure --with-mysql=/usr/local/mysql --with-apache=/usr/src/apache_1.3.19
--enable-ftp --enable-discard-path --with-pdflib=/usr/lib --with-gd

That's OK! System don't response any error messages!
Then, I compile PHP and Apache source code.

No any error messages during compiling.

But.. It still can't use any pdf functions like pdf_open().
My Linux box will tall me "Fatal error: Call to undefined function.."

I tried to compile PHP with PDFlib again,
and saw some information:

(1)
checking whether to include PDFlib support... yes

(2)
creating ext/ftp/Makefile
creating ext/gd/Makefile
creating ext/mysql/Makefile
creating ext/pcre/Makefile
creating ext/pcre/pcrelib/Makefile
creating ext/posix/Makefile
creating ext/session/Makefile
creating ext/standard/Makefile
creating ext/xml/Makefile
creating ext/xml/expat/Makefile
creating ext/xml/expat/xmlparse/Makefile
creating ext/xml/expat/xmltok/Makefile

==> It did not create ext/pdf/Makefile!


P.S: Before compile PHP, I have updated the PHP source sode from PHP and Zend CVS.
My commands are:
==> # cvs -d :pserver:cvsread@cvs.php.net:/repository co php4
==> # cd php4
==> # cvs -d :pserver:cvsread@cvs.zend.com:/repository co Zend TSRM
==> # cp -r * /usr/src/php-4.0.5/

Is this a bug at php-4.0.5?
How can I do that you recommend?


<b>P.S: I did checkout the CVS on May 22 morning in Taiwan. </b>
 [2001-05-22 18:45 UTC] sniper@php.net
Please check your config.log. Most likely there
is some missing library.

--Jani

 [2001-05-22 19:57 UTC] leo at sayya dot org
I saw the config.log file, search keyword: pdf and found one line only:

configure:9682: checking whether to include cpdflib support

Is cpdflib same to pdflib?
Should I install cpdflib?
 [2001-05-22 23:50 UTC] sniper@php.net
You are using wrong paths in the configure options.
You should use the INSTALL paths of the libs, not the libpath. ie. --with-pdf=/usr

--Jani

 [2001-05-23 04:51 UTC] leo at sayya dot org
If I configure pdflib with this path '/usr',
it'll tell me 'checking for PDF_show_boxed in -lpdf... no'
So, I don't think so that my path wrong..
Any other suggest? Thanks!

checking for Ovrimos SQL Server support... no
checking whether to include PCRE support... yes
checking for memmove... (cached) yes
checking whether to include PDFlib support... yes
checking for libz needed by pdflib 3.x... already zlib support
checking for jpeg_read_header in -ljpeg... (cached) yes
checking for png_create_info_struct in -lpng... no
no
checking for TIFFOpen in -ltiff... no
no
checking for PDF_show_boxed in -lpdf... no
configure: error: pdflib extension requires pdflib 3.x.
[root@dns php-4.0.5]#

 [2001-05-23 10:11 UTC] danbeck@php.net
PDFlib requires that you have the JPEG and TIFF libraries available when you compile PHP.  This means that you need to have the --with-jpeg-dir=[DIR] and --with-tiff-dir=[dir] configure options alongside of --with-pdf=[DIR].  Please see:
 http://php.net/manual/en/install.configure.php#install.configure.with-pdflib

For details on compile options.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 10:01:26 2019 UTC