php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10985 Cannot load /usr/local/apache/libexec/libphp4.so into server: shared object not
Submitted: 2001-05-21 08:16 UTC Modified: 2001-05-21 12:58 UTC
From: ronpflaumer at inkwell dot freeserve dot co dot uk Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.5 OS: SuSe 7.1
Private report: No CVE-ID: None
 [2001-05-21 08:16 UTC] ronpflaumer at inkwell dot freeserve dot co dot uk
I am running Suse Linux 7.1 with kernel 2.4 on a P233MMX Fujitsu Myrica Plus.

Configure line for php4.0.5:
#./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs
I was following a routine from ibm.com/developerworks and had succeeded with installing apache_1.2.19 and MySQL-3.23.38.
I copied php.ini-dist into /usr/local/lib/php.ini and edited the apache conf file to include
AddType application/x-httpd-php .php .phtml
AddType application/x-httpd-source .phps
I saved the file, then restarted apache and got a message that apache could not be started because it could not load 
/usr/local/apache/libexec/libphp4.so into server: shared object not open.
Do you have a solution?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-21 12:58 UTC] sniper@php.net
This is certainly not any bug in PHP. 
Please ask support questions on one of the mailing
lists, ie. php-install@lists.php.net or php-general@lists.php.net

Hint: /etc/ld.so.conf , /sbin/ldconfig

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Dec 04 14:05:54 2022 UTC