php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10884 Cookies not set
Submitted: 2001-05-15 14:48 UTC Modified: 2001-05-23 16:51 UTC
From: mad at dactar dot ch Assigned:
Status: Closed Package: Variables related
PHP Version: 4.0.5 OS: HPUX 10.20
Private report: No CVE-ID: None
 [2001-05-15 14:48 UTC] mad at dactar dot ch
Hellow,

Here's a problem with Cookies Management :

When I define several (eg. 3 ) cookies outside php (eg. in a cgi shell-script), the HTTP_COOKIE variable is set but not HTTP_COOKIE_VARS array in php.

Then when I define another Cookie with SetCookie with php, HTTP_COOKIE contain all Cookies, but HTTP_COOKIE_VARS contains only this Cookie.

An idea ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-23 00:15 UTC] mad at dactar dot ch
It's a bug or not ???
 [2001-05-23 16:51 UTC] mad at dactar dot ch
Okay...

When we set a cookie in a shell script's cgi with echo "Set-Cookie: USER=$USER", we MUST replace it with echo "Set-Cookie: USER=$USER ; PATH=/"

Sorry for this false bug...

Bon...

Alors le truc c'est que quand on d?fini un cookie dans un cgi, on oublie souvent que l'on est dans /cgi-bin quand on essaie de r?cup?rer le cookie dans un autre script....ajouter PATH=/ apr?s chaque d?finition de cookie, et on pourra les reprendre d'office avec PHP

Je me suis bien arrach? les cheveux mis ? part ?a :P

D?sol? pour ce faux bug

@++
JC
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 23:01:25 2019 UTC