php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10832 memory overruns in php_rshutdown_session_globals
Submitted: 2001-05-12 16:38 UTC Modified: 2001-06-08 13:21 UTC
From: wez@php.net Assigned:
Status: Closed Package: Session related
PHP Version: 4.0 Latest CVS (2001-05-12) OS: SuSE 7.0 i386
Private report: No CVE-ID: None
 [2001-05-12 16:38 UTC] wez@php.net
I'm really puzzled by this one; at first I thought it was a bug in my extension, but after running apache under gdb I found the problem in the sessions module.

It's hard to describe and I can't reproduce it with a simple script :-(

During the call to php_rshutdown_session_globals, zend reports a memory overrun while calling zend_hash_destroy(&PS(vars));

Sometimes it's a little overrun, but other times it's enough to segfault.

I'm using a user level session handler which works against mysql.  I tried switching to mm but I get a segfault every time when using mm :-(

I believe this is the cause of the random "loss" of a session variable that I mentioned last week on php-dev.

I have no idea what's causing it; if there is anything I can provide to help, let me know.

My configure line is:

"./configure" \
"--with-apxs" \
"--disable-pear" \
"--enable-debug" \
"--enable-sigchild" \
"--enable-calendar" \
"--enable-ftp" \
"--with-ldap" \
"--with-mysql=/usr" \
"--enable-shmop" \
"--enable-sysvsem" \
"--enable-sysvshm" \
"--with-zlib" \
"--enable-inline-optimization" \
"--with-iconv" \
"--with-bz2" \
"--with-openssl" \
"--enable-bcmath" \
"--enable-ctype" \
"--with-imap" \
"--with-pspell" \
"--enable-yp" \
"--with-jpeg-dir" \
"--with-png-dir" \
"--with-freetype-dir" \
"--with-gd" \
"--with-mhash" \
"--enable-mailparse" \
"--enable-mbstring" \
"--with-cybercash=/usr/local/mck-3.2.0.3-linux" \
"--with-savi=/home/CLIENTWEB/sophosantivirus/sav_if" \
"--enable-php-streams" \
"--enable-mbregex" \
"--enable-memory-usage-info" \
"$@"

(The non-standard extensions are not being used in the scripts with problems).

I've removed mm support from my build because it didn't help at all.

--Wez.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-08 13:21 UTC] sas@php.net
Submitter forgot to close.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Feb 02 01:03:57 2023 UTC