php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10788 c-client linked to config test progs causes undefined symbols
Submitted: 2001-05-10 09:56 UTC Modified: 2001-05-11 16:36 UTC
From: wez@php.net Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0 Latest CVS (2001-05-10) OS: SuSE 7.0 i386
Private report: No CVE-ID: None
 [2001-05-10 09:56 UTC] wez@php.net
The conftest progs for things like setuid fail because c-client expects to find "mm-expunged", "mm_diskerror" etc. etc.

Probably related to current build issues, but not enough of an autoconf guru to figure it out.

"./configure" \
"--with-apxs" \
"--disable-pear" \
"--enable-debug" \
"--enable-sigchild" \
"--enable-calendar" \
"--enable-ftp" \
"--with-ldap" \
"--with-mysql=/usr" \
"--enable-shmop" \
"--enable-sysvsem" \
"--enable-sysvshm" \
"--with-zlib" \
"--enable-inline-optimization" \
"--with-iconv" \
"--with-bz2" \
"--enable-wddx" \
"--with-openssl" \
"--enable-bcmath" \
"--enable-ctype" \
"--with-imap" \
"--with-pspell" \
"--enable-yp" \
"--with-jpeg-dir" \
"--with-png-dir" \
"--with-freetype-dir" \
"--with-gd" \
"--with-mhash" \
"--enable-mailparse" \
"--enable-jstring" \
"--with-cybercash=/usr/local/mck-3.2.0.3-linux" \
"--enable-php-streams" \
"--enable-mbregex" \
"--enable-memory-usage" \
"--with-mm" \
"$@"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-10 16:03 UTC] chagenbu@php.net
I see this also; Jani's latest commit didn't fix it. Here's the config.log entry:

configure:51043: checking whether to include zlib support
configure:51244: checking for gzgets in -lz
configure:51263: gcc -o conftest -g -O2  -DLINUX=2 -DEAPI -DTARGET="apache" -DUSE_HSREGEX -DUSE_EXPAT -DSUPPORT_UTF8 -DXML_BYTE_ORDER=12 -L/usr/lib  -Wl,-rpath,/home/chuck/code/imap/lib -L/home/chuck/code/imap/lib -Wl,-rpath,/home/chuck/code/mcal/libmcal -L/home/chuck/code/mcal/libmcal conftest.c -lz  -lmysqlclient -lmcal -lldap -llber -lc-client -lcrypt -lresolv -lm -ldl -lnsl  -lresolv 1>&5
/usr/lib/libc-client.so: undefined reference to `mm_expunged'
/usr/lib/libc-client.so: undefined reference to `mm_diskerror'
/usr/lib/libc-client.so: undefined reference to `mm_lsub'
/usr/lib/libc-client.so: undefined reference to `mm_flags'
/usr/lib/libc-client.so: undefined reference to `mm_fatal'
/usr/lib/libc-client.so: undefined reference to `mm_nocritical'
/usr/lib/libc-client.so: undefined reference to `mm_notify'
/usr/lib/libc-client.so: undefined reference to `mm_searched'
/usr/lib/libc-client.so: undefined reference to `mm_status'
/usr/lib/libc-client.so: undefined reference to `mm_login'
/usr/lib/libc-client.so: undefined reference to `mm_list'
/usr/lib/libc-client.so: undefined reference to `mm_critical'
/usr/lib/libc-client.so: undefined reference to `mm_exists'
/usr/lib/libc-client.so: undefined reference to `mm_log'
/usr/lib/libc-client.so: undefined reference to `mm_dlog'
collect2: ld returned 1 exit status
configure: failed program was:
#line 51252 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gzgets();

int main() {
gzgets()
; return 0; }

 [2001-05-11 15:26 UTC] sniper@php.net
This should be fixed now.
Reopen if not.

--Jani

 [2001-05-11 16:36 UTC] chagenbu@php.net
confirmed fix
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 16:05:48 2023 UTC