|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10780 apache segmentation fault with
Submitted: 2001-05-10 05:34 UTC Modified: 2001-06-02 20:48 UTC
From: christoph dot hofstetter at bit dot admin dot ch Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.5 OS: aix 4.3.3
Private report: No CVE-ID: None
 [2001-05-10 05:34 UTC] christoph dot hofstetter at bit dot admin dot ch
when I try to restart Apache after installing PHP4_mod (, it dies:

/usr/local/apache/bin/apachectl[124]: 61546 Segmentation fault(coredump)

configure was run as follows:

./configure --with-oracle \                  
--with-apxs=/usr/local/apache/bin/apxs \     
--with-oci8 \                                
--enable-discard-path \                      
--without-mysql \                            

I tried this with Oracle 8.1.7 and 8.1.6, and also with PHP 4.0.4, same result.

do I do something wrong?                         


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-10 05:42 UTC]
Could you please generate a GDB backtrace?
First reconfigure with --enable-debug of course.

rm config.cache
./configure .. <your options + --enable-debug>
make clean
make install

and then try generating the backtrace.


 [2001-05-10 08:13 UTC] christoph dot hofstetter at bit dot admin dot ch

Core was generated by `httpd'.                                       
Program terminated with signal 11, Segmentation fault.               
#0  0xd2ebbba4 in ap_register_cleanup ()                             
Setting up the environment for debugging gdb.                        
.gdbinit:5: Error in sourced command file:                           
Function "internal_error" not defined.                               
(gdb) bt                                                             
#0  0xd2ebbba4 in ap_register_cleanup ()                             
#1  0xd2ebd030 in php_create_dir ()                                  
#2  0x10018634 in ap_single_module_configure ()                      
#3  0x10044918 in load_module ()                                     
#4  0x1001607c in invoke_cmd ()                                      
#5  0x10016f00 in ap_handle_command ()                               
#6  0x10016ff0 in ap_srm_command_loop ()                             
#7  0x100177e8 in ap_process_resource_config ()                      
#8  0x100184b8 in ap_read_config ()                                  
#9  0x10006938 in main ()                                            
#10 0x100001dc in __start ()                                         

 [2001-05-10 12:01 UTC]
Which Apache version is this? 
And obviously your is not configured
with --enable-debug..

Does it work without Oracel support?


 [2001-05-23 12:08 UTC] christoph dot hofstetter at bit dot admin dot ch
here is the information you asked for. I did my best to configure php with --enable-debug, but I am not sure if I produced the backtrace correctly: gdb <path/to/httpd> <path/to/core>
As you can see, I configured without oracle support, but I still get the segmentation fault

Apache version: Apache/1.3.12 (Unix)

first lines of config.status

#! /bin/sh
# Generated automatically by configure.
# Run this file to recreate the current configuration.
# This directory was configured as follows,
# on host vela:
# ./configure  --with-apxs=/usr/local/apache/bin/apxs --enable-debug --enable-di
scard-path --without-mysql --enable-track-vars

some lines from the output of configure:

checking for Apache module support via DSO through APXS... yes
checking for Apache 2.0 module support via DSO through APXS... no
checking whether to include debugging symbols... yes

 [2001-06-02 20:48 UTC]
This should be fixed with PHP 4.0.6, please try the 
latest release candidate:


PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 23:01:28 2024 UTC