php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10779 error in configure script (oracle release checks)
Submitted: 2001-05-10 05:23 UTC Modified: 2001-05-10 05:27 UTC
From: christoph dot hofstetter at bit dot admin dot ch Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.5 OS: aix 4.3.3
Private report: No CVE-ID: None
 [2001-05-10 05:23 UTC] christoph dot hofstetter at bit dot admin dot ch
the configure script contains an error where it checks the oracle release for oracle_ORACLE support, around line 30756:

it sets variable OCI8_VERSION instead of ORACLE_VERSION



  if test -s "$ORACLE_DIR/orainst/unix.rgs"; then
  	ORACLE_VERSION=`grep '"ocommon"' $ORACLE_DIR/orainst/unix.rgs | sed 's/  */:/g' | cut -d: -f 6 | cut -c 2-4`
	test -z "$ORACLE_VERSION" && ORACLE_VERSION=7.3
  elif test -f $ORACLE_DIR/lib/libclntsh.s?.8.0; then
    ORACLE_VERSION=8.1
  elif test -f $ORACLE_DIR/lib/libclntsh.s?.1.0; then
    ORACLE_VERSION=8.0
  elif test -f $OCI8_DIR/lib/libclntsh.a; then
    if test -f $OCI8_DIR/lib/libcore4.a; then
      OCI8_VERSION=8.0  --> should be ORACLE_VERSION!!!
    else
      OCI8_VERSION=8.1  --> should be ORACLE_VERSION!!!
    fi
  else
  	{ echo "configure: error: Oracle needed libraries not found" 1>&2; exit 1; }
  fi
  echo "$ac_t""$ORACLE_VERSION" 1>&6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-10 05:27 UTC] sniper@php.net
Fixed in CVS now.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 20:03:35 2022 UTC