php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10758 php_curl.dll won't load, even if in WinNT\system32 folder
Submitted: 2001-05-09 13:32 UTC Modified: 2001-05-09 15:51 UTC
From: bryan dot keller at pfizer dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.4pl1 OS: WinNT 4.0
Private report: No CVE-ID: None
 [2001-05-09 13:32 UTC] bryan dot keller at pfizer dot com
I've tried every suggestion from the documentation and users on this issue, and I'm convinced that there is a bug. Other extensions will load without error. Php_curl.dll won't even load if it is placed in the winnt\system32 folder, and surrounded by its required modules (with the .ini file pointing to the system32 folder for extensions directory).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-09 13:52 UTC] jmoore@php.net
Please contact php-install@lists.php.net or php-general@lists.php.net I know that all the extensions will load as I use them here. Are you given any errors when starting the php.exe from command line mode?? Reopen if you can provide more information about what is happening.. As it is at the moment you havnt provided us enough information to work with.

cheers,

- James 
 [2001-05-09 14:12 UTC] bryan dot keller at pfizer dot com
Yes there is an error when executing php.exe from the command line:

The procedure entry point add_assoc_string_ex could not be located in the dynamic link library php4ts.dll

Then you get the php_curl error:

Unable to load dynamic link library 'c:\php\extensions\php_curl.dll' - The specified procedure could not be found

(sorry for my previous vagueness)
 [2001-05-09 14:13 UTC] bryan dot keller at pfizer dot com
Yes there is an error when executing php.exe from the command line:

The procedure entry point add_assoc_string_ex could not be located in the dynamic link library php4ts.dll

Then you get the php_curl error:

Unable to load dynamic link library 'c:\php\extensions\php_curl.dll' - The specified procedure could not be found

(sorry for my previous vagueness)
 [2001-05-09 14:21 UTC] jmoore@php.net
Looks like it could be stale php4ts.dll's hanging about please delete any that are lying about on your computer and then reinstall PHP again and this will hopefully fix the problem (check system32 dir, system dir ect). Make sure your php_curl.dll isnt stale too.

- James
 [2001-05-09 14:43 UTC] bryan dot keller at pfizer dot com
Yes there is an error when executing php.exe from the command line:

The procedure entry point add_assoc_string_ex could not be located in the dynamic link library php4ts.dll

Then you get the php_curl error:

Unable to load dynamic link library 'c:\php\extensions\php_curl.dll' - The specified procedure could not be found

(sorry for my previous vagueness)
 [2001-05-09 15:16 UTC] bryan dot keller at pfizer dot com
okay, I think i'm getting to the heart of the issue here:

when I disable the php_curl.dll extension in the php.ini file, php.exe (4.0.4pl1) starts up fine from the command line. When I enable the curl extension, it tells me I'm missing MSVCR70.dll, which I have gathered is an old C runtime library.

No one seems to have it (least of all microsoft), yet php_curl requires it, no?


 [2001-05-09 15:51 UTC] bryan dot keller at pfizer dot com
Possible Solution:

To use the php_curl.dll in NT 4.0, I made a copy of the msvcrt.dll library included in the PHP distribution. I renamed the copy to msvcr70.dll and moved it to my winnt\system32 folder. This seems to fool php_curl into thinking it is using the old library, but apparently the new library works similarly.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 19:05:54 2022 UTC