php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10726 cant catch post data from stdin in cgi-bin
Submitted: 2001-05-08 04:56 UTC Modified: 2001-05-08 07:16 UTC
From: ondi at 21 dot ru Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: 4.0.4pl1 OS: solaris 7
Private report: No CVE-ID: None
 [2001-05-08 04:56 UTC] ondi at 21 dot ru
hi there is a trouble with catching stdin with post data in the cgi-bin php script. I did disable track_vars, but I still unable to catch any data in stdin, and all data still present in the $PHP_POST_VARS[];
is there any solution?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-08 06:25 UTC] jmoore@php.net
Bogus.. Looks like your trying to do somthing thats not supported.. I dont know where your getting $PHP_POST_VARS from as it should be $HTTP_POST_VARS you should fopen("php://stdin","r"); if your doing what I think you are..

- James
 [2001-05-08 07:16 UTC] ondi at 21 dot ru
Im trying to post XML data to the chi-bin php script, that shold parse that data and deal with it tags!
So php catch all my stdin before! and I cant reach my XML!

Sorry that was my mistake about $PHP_POST_VARS it should be $HTTP_POST_VARS of course.

if I do fopen("php://stdin", "r") I'll read nothing!!!
because of php did it before!

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC