php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10723 error max_execution_time, unrelated to value in php.ini
Submitted: 2001-05-08 00:09 UTC Modified: 2001-05-16 02:43 UTC
From: steffen dot schreiner at lgl dot de Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.0.5 OS: Linux SuSE 6.4
Private report: No CVE-ID: None
 [2001-05-08 00:09 UTC] steffen dot schreiner at lgl dot de
It's a problem with a big (2MB or greater) file upload. After the file is up, the message "Fatal error: Maximum execution time of 2 seconds exceeded" appears, but the parameter max_execution_time in php.ini hasn't this value, nor the error is influenced by any value for set_time_limit in the php.ini.

The Skripts are:

action.php
----------
<?
$maxupload = "10485760";
echo '<form action="mail.php" method="POST" ENCTYPE="multipart/form-data"  name="neumail">
<INPUT TYPE="hidden" name="MAX_FILE_SIZE" value="$maxupload">
<input type="file" size="35" name="attach" value="">
<input type="submit" name="BLIND" value="  Ok  ">';
?></body></html> 
----------

mail.php
----------
<? $fp = fopen($attach,'r'); while (!feof ($fp))
 { $attachment .= fgetc($fp); }?>
----------


It can be testet at:
http://www.lgl.de/mail/debug/action.php
http://www.lgl.de/mail/debug/mail.php
http://www.lgl.de/mail/debug/phpinfo.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-08 03:01 UTC] derick@php.net
Can you add a call to phpinfo() at the end of the action.php and mail.php scripts?
 [2001-05-08 06:15 UTC] steffen dot schreiner at lgl dot de
OK,on both Sktipts I've added phpinfo().
 [2001-05-08 06:20 UTC] derick@php.net
The mail.php script gives this error:

   Warning: fopen("","r") - Inappropriate ioctl for device in
   /usr/local/httpd/htdocs/mail/debug/mail.php on line 2
   Warning: Supplied argument is not a valid File-Handle resource in
   /usr/local/httpd/htdocs/mail/debug/mail.php on line 3
   Warning: Supplied argument is not a valid File-Handle resource in
   /usr/local/httpd/htdocs/mail/debug/mail.php on line 5
   Warning: Supplied argument is not a valid File-Handle resource in
   /usr/local/httpd/htdocs/mail/debug/mail.php on line 3

Please fix that first, as this occured for a 10 bytes file
 [2001-05-08 07:15 UTC] steffen dot schreiner at lgl dot de
These File-handle errros I only become if I don't give the mail-Skript a file-handle. By sending a request through action.php I've no such File-handle errors. I've tried it several times. Maybe the file-handle isn't given correctly to the Skript ?!
 [2001-05-16 02:43 UTC] sniper@php.net
I can't reproduce this. And your scripts are buggy.
Try looking at the source for the page for action.php 

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Oct 13 20:01:26 2019 UTC