php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10720 Error Parsing Browscap.ini
Submitted: 2001-05-07 21:08 UTC Modified: 2001-05-10 10:35 UTC
From: istvan at siposs dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.5 OS: Windows 2000 Professional
Private report: No CVE-ID: None
 [2001-05-07 21:08 UTC] istvan at siposs dot com
When I modify my php.ini file and point the browscap configuration setting to the browscap.ini provided with PHP (under c:\php\browscap\browscap.ini) I get the following error at the end of every php page:

PHP: Error parsing c:\php\browscap\browscap.ini on line 8206 

If I use the default browscap.ini installed by Windows itself, the error does not happen.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-10 05:11 UTC] sniper@php.net
There are no browscap.ini files bundled with PHP.

--Jani

 [2001-05-10 10:35 UTC] istvan at siposs dot com
That's odd. I downloaded the Win32 Zip version from the download page here. I unzipped the package to c:\php, and under this tree a directory called browscap was created with a browscap.ini file. In fact, I'm just looking at the contents of the zip file php-4.0.5-Win32.zip and it has a browscap\browscap.ini in it. This was the browscap.ini file that I was referring to.

Istvan Siposs
 [2002-04-06 22:22 UTC] katsuey at katsuey dot com
I also received a browscap/browscap.ini file in my download of PHP Triad and I received the same error notice about line 8206 when attempting to use Komodo (ActiveState.com).  I'm on WinXP
 [2004-05-06 00:20 UTC] ivan dot roth at free dot fr
Maybe you will read this if you were patient for answers! :)

www.ivan-roth.com/test.zip

this could help you! Extract it in the same directory that browscap.ini and run it. It will creat a browscap.ini.new file. delete browscap.ini and rename browscap.ini.new into browscap.ini. This file will then be compatible with PHP. It worked for me. I hope it'll work for you too.

But I hope that you are not blocked by this problem since 3 years! :)

Bye, Ivan.
 [2004-06-21 21:47 UTC] michael83_2 at hotmail dot com
I get the same error and it's not fixed with the test.zip file. It makes a empty browscap.ini file.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Mar 24 08:01:26 2019 UTC