php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10708 modphp crashes if cascaded includes occur
Submitted: 2001-05-07 11:27 UTC Modified: 2001-05-08 09:44 UTC
From: estartu at augusta dot de Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.5 OS: FreeBSD 4.3-STABLE (not improtan
Private report: No CVE-ID: None
 [2001-05-07 11:27 UTC] estartu at augusta dot de
I maintain a WebSite with mixed php and SSI pages. SSI is used to
maintain a corporated design for all Pages. So all php Pages include
the standard ssi framework. So far everything works fine

Now i have tried to include a php script from the ssi framework  with 
<!--virtual -->

if i Do this mod php crashes after the subrequest for the ssi framework 
is finished and control is returnd to mod php. As far as I can tell the 
included php script is executed without errors.  

gdb backtrace says 

#0  0x816086a in execute (op_array=0x82c9a00) at ./zend_execute.c:1523
#1  0x8160a35 in execute (op_array=0x82c928c) at ./zend_execute.c:1559
#2  0x812392b in zend_execute_scripts (type=8, file_count=3) at zend.c:729
#3  0x80904ac in php_execute_script (primary_file=0xbfbfda14) at main.c:1221
#4  0x81360f7 in apache_php_module_main (r=0x82bd3e4, display_source_mode=0)
    at sapi_apache.c:89
#5  0x808cea6 in send_php (r=0x82bd3e4, display_source_mode=0, 
    filename=0x82bd9a4 "/usr/local/www/virt/inga/htdocs/termine/index.php3")
    at mod_php4.c:516
#6  0x808cee0 in send_parsed_php (r=0x82bd3e4) at mod_php4.c:527
#7  0x816c553 in ap_invoke_handler (r=0x82bd3e4) at http_config.c:517
#8  0x8182a19 in process_request_internal (r=0x82bd3e4) at http_request.c:1303
#9  0x8182e94 in ap_internal_redirect (
    new_uri=0x82bd3a4 "/termine/index.php3", r=0x82bc034)
    at http_request.c:1427
#10 0x807943d in handle_dir (r=0x82bc034) at mod_dir.c:174
#11 0x816c553 in ap_invoke_handler (r=0x82bc034) at http_config.c:517
#12 0x8182a19 in process_request_internal (r=0x82bc034) at http_request.c:1303
#13 0x8182a7c in ap_process_request (r=0x82bc034) at http_request.c:1319
#14 0x8178cc9 in child_main (child_num_arg=0) at http_main.c:4208
#15 0x8178e88 in make_child (s=0x820e034, slot=0, now=989249079)
    at http_main.c:4312
#16 0x8179013 in startup_children (number_to_start=1) at http_main.c:4394
#17 0x8179664 in standalone_main (argc=2, argv=0xbfbfdc28) at http_main.c:4682
#18 0x8179fd3 in main (argc=2, argv=0xbfbfdc28) at http_main.c:5009

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-07 18:01 UTC] zeev@php.net
Can you check if the problem persists in the latest CVS?
 [2001-05-08 08:04 UTC] estartu at augusta dot de
I had some problems compiling the cvs version but it
seams to work in the dev version. Than i have tried 
4.0.5 in this version the problem still exists.
 [2001-05-08 09:44 UTC] sniper@php.net
This is fixed. Fix will be in 4.0.6.

--Jani

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 12:01:28 2024 UTC