php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10631 Incorrectly reported line number on errors with Mac line-breaks
Submitted: 2001-05-03 06:21 UTC Modified: 2001-05-03 08:32 UTC
From: basil dot hussain at specialreserve dot net Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.4pl1 OS: Linux 2.2.14
Private report: No CVE-ID: None
 [2001-05-03 06:21 UTC] basil dot hussain at specialreserve dot net
When a file is saved using Macintosh-style line breaks 
('\r') and there is some kind of error in the script (maybe 
a parse error, etc.) then the line number that is reported 
is always line 1.

It's a fairly minor thing, but annoying nonetheless. A 
workaround, obviously, is to make sure you save your 
scripts with Unix line-breaks ('\n').

This sounds like it's related to (and may have been fixed 
along with) bug #10578. However, in my experience it has 
been in existence since PHP 4 was first released and 
possibly even in PHP3. Maybe I should have reported it 
sooner... :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-03 06:26 UTC] derick@php.net
This is likely fixed in the CVS now. PHP 4.0.6 will have it. Can you please try the latest CVS of PHP (and Zend) to test if it works now?
 [2001-05-03 07:02 UTC] basil dot hussain at specialreserve dot net
Thanks, but unfortunately I can't test it myself as my servers have no C compilation facilities (for security purposes, etc.), so I'll have to wait.

Once 4.0.6 is out, though, if it doesn't solve this problem, I'll post back to this bug report.
 [2001-05-03 07:07 UTC] andi@php.net
Should be fixed in 4.0.6.
Please open a new bug report if the problem persists with 4.0.6
 [2001-05-03 08:21 UTC] basil dot hussain at specialreserve dot net
Thanks, but unfortunately I can't test it myself as my servers have no C compilation facilities (for security purposes, etc.), so I'll have to wait.

Once 4.0.6 is out, though, if it doesn't solve this problem, I'll post back to this bug report.
 [2001-05-03 08:21 UTC] basil dot hussain at specialreserve dot net
Thanks, but unfortunately I can't test it myself as my servers have no C compilation facilities (for security purposes, etc.), so I'll have to wait.

Once 4.0.6 is out, though, if it doesn't solve this problem, I'll post back to this bug report.
 [2001-05-03 08:32 UTC] derick@php.net
should be fixed in 4.0.6.
Please open a new bug report if the problem persists with 4.0.6
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 10:01:29 2024 UTC